FAQ

This error code is responsible for the required reboot of your computer. Most commonly, it is not called by the installation itself, but by the system updates or the previous installations. Hence, you need to reboot your computer, and sometimes it is necessary to do it several times due to the depended processes.


The Auto-update service verifies the presence of a new version of TWS according to a set schedule. If a new version is found, it is downloaded locally and The Welkin Suite is automatically updated during the next restart.


Mostly no — you can view and edit your files, save them offline, but you won’t be able to pull new changes or build your changes without having a connection to the org.


Each TWS license is assigned to the user’s email and can be used on any number of devices that this user works on. A single user’s license can be used on TWS for Windows, as well as on TWS for Mac, so you shouldn’t acquire separate licenses for TWS for different Operating Systems.


The Trial period for using TWS IDE equals 30 days. After you have activated your Trial license, you can easily track the remaining time in several ways:

  • when you restart the IDE, the license information is refreshed and becomes available for you on the start screen,
  • when you re-log in to the IDE, the license information is refreshed and becomes available for you on the start screen,
  • on TWS site in the Profile / My Products / Subscription info you can access all the information about your activated TWS license.

When your license administrator assigns the Enterprise license to your email from the managed Enterprise subscription, the information about the Trial license still being activated may remain visible for you for a while. The reason behind this is triggered by the small delay in license activation. We kindly ask you to check this information again in 10-15 minutes.


All you need to do is to locate your project in your file system and double-click this project or solution file to open it, or you can open The Welkin Suite and open the projects using File ⇒ Open ⇒ Project / Solution or File ⇒ Recent Projects / Solutions menus.


There is a possibility to set one of the several options for the IDE launch. You can find this option the Main Menu: Tools ⇒ Options ⇒ Environment ⇒ Startup. Then select the necessary option from this list:

  • Open Home Page;
  • Load last loaded solution;
  • Show Open Project dialog box;
  • Show New Project dialog box;
  • Show empty environment.

Please close and then reopen the project with the new credentials you saved. Since this process is linked to Salesforce session, the credentials will not be included in the project workflow until the session expires.


This message appears because the file's content was downloaded from SF after the build — SF makes some modifications like removing white spaces, re-ordering the metadata files and so on. We like to keep everything consistent with files on SF and TWS’s locally stored files. You just need to reload your file to make it actual.


The IDE doesn’t allow you to remove or rewrite the changes that were done on Salesforce by other developers during the building of your file(s).

The message, which you have gotten, informs you that such changes were done on the Salesforce side, and it happened while you were editing the file after the pull process for example.

During the pull process, you just get all the new changes, which have been made in the org that you are working with.

If any conflicts are found during the pull process, you can skip, rewrite, or merge them.

See more at the How to Pull changes from Salesforce section.


No, you can save changes in different files and then build them all at once.


No. If any file you have changed was also changed in the Org, you won’t be allowed to build it until you pull its updated version from the Org.


The process of deploying to another organization includes running tests after deploying files. As of now when you are deploying your files in TWS, you have an option to select, which tests you need to be run.


You can find options for the Code Completion in the following way: Tools ⇒ Options ⇒ Text Editor ⇒ Code Assistance.

There are three options available:

  • Show Code Completion when typing;
  • Preselect Completions in Completion List;
  • Show Code Snippets in Completion List.

By default, all these options are selected, but if you do not want to use some of them, you should uncheck them.


Yes, you can create any number of folders with unlimited nesting, and you have the ability to mix all types of files in them — you even are able to have JavaScript or CSS files from the Static Resources in the same folder with the page and its controller. Also, you can remove “Classes” or any other standard folder if they don't fit your project structure.


At the moment, you can synchronize your custom project structure only with Salesforce. Unfortunately, other IDE’s don’t support this great feature so your custom project structure won’t be able there. But you shouldn't worry about this if you and your colleagues always work with The Welkin Suite.


The Welkin Suite automatically unzips and zips Static Resources with less than 20 files in them preserving original folders structure in the archive. You can follow our new updates so you do not miss any information about upcoming enhancements and optimizations for this feature.


Yes, you can remove classes, triggers, pages and components from the org if Salesforce won’t forbid this action or if this won’t break your org.

However, you’re not yet able to delete Static Resources or their content from The Welkin Suite. You can follow our new updates to find out when this feature will be enabled.


When you copy and paste the code it may change the case, and we know how important the case is in Lightning components and applications development. Thus, to solve this problem, you can disable the Format on paste option the following way: Main Menu ⇒ Tools ⇒ Options ⇒ Text Editor ⇒ HTML ⇒ Advanced. There you will see the Paste section with the Format on paste option. Change its value to False.


Yes, you can use Anonymous Apex in The Welkin Suite, and instead of having just a single file with it you will have the ability to create multiple different files with Anonymous Apex snippets to enhance its usability.


Yes, you can easily run unit tests: monitor the execution process and test results on a dedicated panel that has all the required information in just one place.


The deployment validation test-run is the same test job, but it is run only to validate the test class / method.

While the regular test jobs are executed on Salesforce one-by-one (and sometimes it may take too much time due to the large queue, workload of Salesforce, etc.), the deployment validation test-run is executed separately, with the highest priority on a “fake” deployment. Its overhead is max 1 min.


Yes, you can debug any unit test from your org as well as a log file or an Anonymous Apex file. The Welkin Suite gives you the ability to efficiently analyze your code, watching step by step the executing of all the operations and calls.


Yes, you can get all the new logs from the Org and read them directly from The Welkin Suite project while you are working with it.


Yes, you can easily set Debug log levels directly in the IDE without switching to Salesforce settings. This option is available from the Logs panel.

In this section:

This also may be useful:

Last modified: 2017/04/12 15:45

footer image