Resolving conflicts after pulling

When developing, you often work on the same functionality as your colleagues do, and this may cause conflicts in a code.

There are two options to handle merge conflicts that may occur after the pull process. Firstly, you can just override your changes. To achieve this just select a file that should be overwritten and click Next.


Override your changes


The another option is to resolve the conflict by comparing file's versions. To do so, click on the Resolve button.


Resolve pull conflicts


As a result of this action, you will get opened an external merge tool that helps you solve conflicts. If there is no merge tool configured in The Welkin Suite, you can configure it in the Options Menu: Main Menu ⇒ Tools ⇒ Options ⇒ External tools. By default, The Welkin Suite uses the KDiff3 merge tool, but you are able to set your own. Currently, The Welkin Suite supports and automatically determines the following merge tools:

  • Araxis,
  • BeyondCompare3,
  • BeyondCompare4,
  • KDiff3 (bundled as an optional component with The Welkin Suite's full installer),
  • WinMerge.

Provide a merge tool


The comparing process is going in the editor's window inside the IDE, you do not need to switch to another application.

Comparing tool

The Compare feature is a suitable tool for visualizing the differences between the current version of the file and the version that you have selected.


Diff view for comparing the versions


All the changes between the versions are highlighted:

  • a red background means that the content was deleted in the newer version,
  • green highlighting means that the content was added in the most recent version.

However, you can always see this legend in the bottom of the Diff viewer. In addition, you can see a 'map' of the changes across the file right in the scrollbar.

All the options of the Compare tool also can be reached on the Compare Files toolbar.

 

After all the conflicts are resolved, the IDE will show the appropriate status.


The conflict is resolved


Now you have all the necessary files updated with all your changes and changes made by other developers.

In this section:

This also may be useful:

Last modified: 2017/03/22 16:27

footer image