Environment

Environment is the first section in the Options menu. Here you can find all common settings, such as UI, startup behavior, recognition of files, etc.

General

This block allows you to select the UI theme of the IDE and its different settings, set the number of items in the Window menu and recently used lists, enable / disable the status bar, and set the behavior of the Close and Auto Hide buttons.


Options menu - Environment - General


AutoRecover

How often the IDE should save AutoRecover information and how long the IDE should keep it.


Options menu - Environment - AutoRecover


Documents

The rules of working with files, such as detecting outside changes, enabling editing read-only files, options for opening the documents, the Undo function, and showing Miscellaneous files in the Solution Explorer (the last option may be useful in work on logs, for example).


Options menu - Environment - Documents


Find and Replace

Additional settings for the Find and Replace Options: displaying informational and warning messages, and the option to populate the Find What window with text from the editor.


Options menu - Environment - Find and Replace


Fonts and Colors

All the settings related to the interface of the editor.


Options menu - Environment - Fonts and Colors


You can select some necessary option from the list Display items or filter this list using the drop-down list Show settings for.


Fonts and Colors - Show settings for


In this section of the Options menu, you can customize editor's colors, and its elements, code snippets, bookmarks, code highlighting, and much more.

To change the interface of an item, select the necessary options in one or all following fields:

  • Font,
  • Size,
  • Foreground and Background colors (you can select a color from a list or set your custom one using a palette).

At any time, you are able to roll back all your changes for an item clicking on the Use Default button.

Import and Export Settings

Here you can set the folder where the IDE will automatically save your user settings, or select a file with a team's settings for better collaboration.


Options menu - Environment - Import and Export Settings


Keyboard

The options for customizing the hotkeys for almost all the commands.


Options menu - Environment - Keyboard


Quick Launch

An ability to enable / disable the Quick Launch functionality and configure its options, such as showing search results, and shortcuts.


Options menu - Environment - Quick Launch


Startup

Here you can set the behavior of the IDE during startup.


Options menu - Environment - Startup


Tabs and Windows

This section allows you to manage tabs and windows of the IDE: the behavior of the tab well, how to show pinned tabs, if the IDE should show the preview tab and how, and the behavior of auto-hidden windows.


Options menu - Environment - Tabs and Windows


Web Browser

This section helps you to set the home page for the IDE, the search page, how you will see the source of the HTML pages and Internet Explorer Options.


Options menu - Environment - Web Browser

In this section:

This also may be useful:

Last modified: 2017/03/13 14:29

footer image