Scrollbar Enhancements

In The Welkin Suite, the vertical scrollbar is a much more powerful tool than in most other applications. This feature allows you to highlight and preview the code in your file. By default, when you install The Welkin Suite, the scroll bar is in the map mode, which displays thumbnails of the code. The scroll bar can operate in two different modes:

  • Normal — usual scrollbar appearance;
  • Code Map — it displays the visual code map as a scrollbar.

Code Map


Change Tracking

In both modes, the vertical scrollbar will also display some helpful informational markers about your code:

  • errors (displayed as red squares by default) — the scrollbar indicates the position in the code where an error occurred,
  • unsaved changes in the code (displayed as yellow squares by default) — indicates the positions in the code where you have done some changes and these changes haven't been saved yet,
  • saved changes in the code (displayed as green squares by default) — indicates the positions in the code where you have done some changes and you have already saved them,

Changes and errors


  • caret position (displayed as a white bar by default) — indicates where the caret is located in the document;

Cursor position


  • search matches for a selected text (displayed as small violet bars by default) — when you select any text in the editor, it automatically highlights all occurrences of the selected text in the document, this information is also displayed on the scrollbar;
  • search matches for searches performed from the Quick Search panel (displayed as brown squares by default) — all matches for a search term entered in the Quick Search panel are also displayed on the scrollbar;

Search


  • bookmarks (displayed as grey squares by default) — indicates positions of bookmarks in the document.

Bookmarks


In addition, you can duplicate an opened file below the current, and scroll them separately — double-click on the button at the top of the scrollbar.


Duplicate an opened file


To come back to a standard view, you need to reopen a document.

Scrollbar Settings

The Code Map mode can be enabled from the Options Menu: Main Menu ⇒ Tools ⇒ Options… ⇒ Text Editor ⇒ All languages ⇒ Scroll Bars. You can access the Scroll Bar settings by the same way, or you can right-click on the scrollbar and choose Scroll Bar Options…. This page sets options for all languages. To change options for only one language, navigate to the settings for the specific language you need.


Scroll Bar options


Scrollbar Options

You can easily navigate through a document, using options of the scrollbar's context menu. Right-click on any place in the scrollbar and select the option you need:

  • Scroll Here — scrolls a visible part of a document to a selected place,
  • Top — scrolls to the top of a document,
  • Bottom — scrolls to the bottom of a document,
  • Page Up — scrolls a document for one screen up,
  • Page Down — scrolls a document for one screen down,
  • Scroll Up — scrolls a document for one line up,
  • Scroll Down — scrolls a document for one line down,
  • Scroll Bar Options… — opens the Options Menu.

Scrollbar Options

In this section:

This also may be useful:

Last modified: 2017/02/27 14:16

footer image