Output Panel

The Output Panel is a 'technical' panel, which purpose is displaying status information about current actions performed by The Welkin Suite in plain text — mostly about the build process. It can be used in tracking the build process in addition to the icons in the Status bar.


Output Panel


The Output panel is called automatically when you start the build. However, you can change its behavior in the Options Menu: Main Menu ⇒ Tools ⇒ Options ⇒ Projects ⇒ General.


Options of the Output panel


In addition, you can open the Output panel manually from the Main Menu: View ⇒ Output or by using the hotkey Ctrl+Alt+O.


Open the Output panel from the Main Menu


In the Output panel, during a build you can find the following info:

  • files that are going to be built,
  • static resources that are going to be built,
  • list of files with conflicts, if they're blocking the build,
  • build progress (request sent / polling for results / results retrieved / etc.).

The buttons on the panel's top help you to navigate through the build and other messages. You can activate them with the hotkey Ctrl+F (the Quick Search panel will appear).


Search in the Output panel


You are able to:

  • find a message in code,
  • go to the previous / next message (or the hotkeys Shift+F8 and F8),
  • clear all.

Also, for more convenient reading you can toggle word wrap using the special button.

In this section:

This also may be useful:

Last modified: 2017/01/27 16:01

footer image